Update your internet browsers to perform CTMS

7. CTMS
To perform CTMS smoothly, please ensure that the internet browser which you are using is updated:
 
  Internet browsers Versions that support CTMS
1 Internet Explorer Version 10 and above
2 Google Chrome Version 51 and above
3 Mozilla Firefox Version 46 and above
4 Safari Version 6 and above
 
* If your internet browser is of an earlier version, you will not be able to perform CTMS smoothly.
 

Please refer to the online guide on how to check and update the internet browser, or refer to here on how to check and update the internet browser on mobile.
 
For further assistance, please contact CTMS Support at support@magicsoft-asia.com or 6513 9172.

Add Feedback